Fort Support Forum

Feature announcements, support and general discussion about Fort

You are not logged in.

#1 2017-03-10 21:20:05

Pierrot
Member
Registered: 2017-03-10
Posts: 5

Standalone decrypt not decrypting

Hello

I bought Fort and now during testing I made this test :

I encrypted a file using a key file I already used before for other files.
Then I started standalone decrypt tool , added a file and asked to decrypt. Pointed to the key file and ... Got message it failed to decrypt

Then I came back to licenced Fort program and it decrypted the file without error . So error is in the decrypt tool I think

Not very important except if we send a file and ask partner to use standalone tool

Otherwise efficent program so far !

Pierre

Offline

#2 2017-03-10 21:28:10

nrosvall
Lead developer
From: Finland
Registered: 2016-07-07
Posts: 62
Website

Re: Standalone decrypt not decrypting

Hi Pierre,

Thanks for your bug report! Seems an annoying problem, I need to investigate what's happening.

Thank you for your purchase!

Offline

#3 2017-03-10 21:49:19

nrosvall
Lead developer
From: Finland
Registered: 2016-07-07
Posts: 62
Website

Re: Standalone decrypt not decrypting

Hi, I just tested this. For me it works ok. I did try using password + keyfile as well as only keyfile and it works as excepted. Are you sure there was no password used with a keyfile during the encryption?

Offline

#4 2017-03-10 21:52:26

nrosvall
Lead developer
From: Finland
Registered: 2016-07-07
Posts: 62
Website

Re: Standalone decrypt not decrypting

If possible, please also give the exact error message.

Cheers,
Niko

Offline

#5 2017-03-10 22:19:21

Pierrot
Member
Registered: 2017-03-10
Posts: 5

Re: Standalone decrypt not decrypting

uhhh Niko Very quick response ! Impressive !

So I tested again with both x86 or x64 versions:  same error
I tested with password and new keyfile : same error

Message is "Fort failed to decrypt one or more files"

All exe's were downloaded today
Tomorrow I will reboot everything and test on clean environment : I will give better results ;-)
*Thanks

Offline

#6 2017-03-14 12:10:02

Pierrot
Member
Registered: 2017-03-10
Posts: 5

Re: Standalone decrypt not decrypting

Hi Niko
Here is a screen record to show you !: maybe I'm doing something wrong but no decrypt is working with standalone tool ...
https://youtu.be/qoScYut3ISY

Offline

#7 2017-03-14 15:20:10

nrosvall
Lead developer
From: Finland
Registered: 2016-07-07
Posts: 62
Website

Re: Standalone decrypt not decrypting

It seems you're doing everything right. I will make a clean test machine and try to reproduce that! Sorry about this.

Offline

#8 2017-03-15 17:11:48

nrosvall
Lead developer
From: Finland
Registered: 2016-07-07
Posts: 62
Website

Re: Standalone decrypt not decrypting

Hi,

Can you try does this work? It's 64bit version of the decryptor. I did make some small changes.

https://cryptoextension.eu/FortDecryptorTest.zip

Offline

#9 2017-03-16 12:47:02

nrosvall
Lead developer
From: Finland
Registered: 2016-07-07
Posts: 62
Website

Re: Standalone decrypt not decrypting

Ok, now I can see the problem. I will try to fix it within a week. It should not be too hard to fix.

Offline

#10 2017-03-16 12:48:41

nrosvall
Lead developer
From: Finland
Registered: 2016-07-07
Posts: 62
Website

Re: Standalone decrypt not decrypting

The problem is happening only when keyfile is used. If only password is used for encryption, the decrypt tool works ok.

Offline

#11 2017-03-16 15:50:13

nrosvall
Lead developer
From: Finland
Registered: 2016-07-07
Posts: 62
Website

Re: Standalone decrypt not decrypting

Thank you for finding this bug. Fortunately it's easy to fix, it's just a logic error in our code. I'll try to make Fort 3.1 during the weekend which fixes this issue.

Offline

#12 2017-03-17 06:15:39

nrosvall
Lead developer
From: Finland
Registered: 2016-07-07
Posts: 62
Website

Re: Standalone decrypt not decrypting

Problem is now fixed in FortDecryptionTool, Fort Portable as well as the standard Fort. Before upgrading to 3.1, it's recommended to decrypt all your files using Fort 3.0. After upgrading you can of course encrypt them again.

Offline

#13 2017-03-17 06:46:52

Pierrot
Member
Registered: 2017-03-10
Posts: 5

Re: Standalone decrypt not decrypting

Thanks for your support : I will upgrade to 3.1

Thanks again

Offline

#14 2017-03-17 07:32:45

nrosvall
Lead developer
From: Finland
Registered: 2016-07-07
Posts: 62
Website

Re: Standalone decrypt not decrypting

Thank you for finding the bug!

Offline

#15 2017-03-18 17:25:58

Pierrot
Member
Registered: 2017-03-10
Posts: 5

Re: Standalone decrypt not decrypting

I confirm it now works like a charm :-)

Thanks for great tool !

Offline

#16 2017-03-18 18:12:35

nrosvall
Lead developer
From: Finland
Registered: 2016-07-07
Posts: 62
Website

Re: Standalone decrypt not decrypting

Good to hear!

Offline

Board footer

Powered by FluxBB